Installation

Installation


The Buckaroo Payments Plugin for Magento 1 enables a ready-to-sell payment gateway.
You can choose from popular online payment methods in The Netherlands, Belgium, France, Germany and globally.

We recommend first installing the plugin in a test environment and make a back-up of your webshop before you do the installation. Make sure that you've made a backup.

Requirements

• A Buckaroo account - Click here to get started
• Magento 1
• Tested on PHP 7.2.0 & 7.4.0

Magento1_download_button


Composer installation

It is possible to install the Buckaroo plugin with composer.
Easy to install, update and maintain.

1. Installation

Login with SSH and execute the following commands via the command line:

Shell
composer require buckaroo/magento1


2. Extension activation and updates

Execute the following commands via the command line:

Shell
cp -ra vendor/buckaroo/magento1/app/* YOUR_MAGENTO_INSTALLATION_ROOT/app
cp -ra vendor/buckaroo/magento1/skin/* YOUR_MAGENTO_INSTALLATION_ROOT/skin

3. File access rights

Depending on the operating system, make sure the just added files have the correct access rights so that the web server can access and execute the files correctly.

The composer command can be executed by the logged in user on the server which is sometimes not the same as the user of the web server. The files created by composer can not be read by the web server which can lead to unexpected behaviour.

Composer will install the files in:

vendor/buckaroo/magento1

4. Flush cache and sessions

Flush your Magento cache using the following command:

Shell
rm -rf MAGENTO_INSTALLATION_ROOT/var/cache/*
rm -rf MAGENTO_INSTALLATION_ROOT/var/session/*

The installation is now completed.


Update the extension

To be able to make use of the latest features and bugfixes you should update the extension frequently. To do this you have to execute the following commands and flush your Magento cache.

Shell
composer update buckaroo/magento1



Updating from older plugin versions

IMPORTANT NOTE:

If you update from v5.0.1 or lower to v5.2.2 or higher then you need also execute :

Shell
composer remove tig/buckaroo-magento1


IMPORTANT NOTE:

If you update from v5.2.2 or lower to v5.3.0 or higher then you need also execute :

Shell
rm -rf MAGENTO_INSTALLATION_ROOT/app/code/community/TIG
rm -rf MAGENTO_INSTALLATION_ROOT/app/design/adminhtml/default/default/layout/TIG/buckaroo3extended.xml
rm -rf MAGENTO_INSTALLATION_ROOT/app/design/frontend/base/default/layout/TIG/buckaroo3extended.xml
rm -rf MAGENTO_INSTALLATION_ROOT/app/etc/modules/TIG_Buckaroo3Extended.xml
rm -rf MAGENTO_INSTALLATION_ROOT/app/locale/en_US/TIG_Buckaroo3Extended.csv
rm -rf MAGENTO_INSTALLATION_ROOT/app/locale/nl_NL/TIG_Buckaroo3Extended.csv
rm -rf MAGENTO_INSTALLATION_ROOT/app/locale/de_DE/TIG_Buckaroo3Extended.csv
rm -rf MAGENTO_INSTALLATION_ROOT/app/locale/de_AT/TIG_Buckaroo3Extended.csv
rm -rf MAGENTO_INSTALLATION_ROOT/skin/adminhtml/default/default/css/tig_buckaroo3extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/adminhtml/default/default/images/tig_buckaroo3extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/adminhtml/default/default/js/tig_buckaroo3extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/adminhtml/default/default/js/TIG/Buckaroo3Extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/frontend/base/default/css/TIG/Buckaroo3Extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/frontend/base/default/images/tig_buckaroo3extended/
rm -rf MAGENTO_INSTALLATION_ROOT/skin/frontend/base/default/js/TIG/Buckaroo3Extended/



Configuration

If you need more help regarding the configuration of the plugin, then please check out our configuration page where you can find a step by step guide.



Please contact Buckaroo support if you have any technical questions.  
E-mail: support@buckaroo.nl

Our telephone number and contact details of other departments can be found in the Buckaroo Payment Plaza under "Contact details" at the bottom left of the screen.


Was this article helpful?

What's Next